Thursday, October 12, 2006

Update - Pella Storm Door has a loose handle

No, I'm not flying off the handle, the handle is flying off. The door. Our wonderful Pella storm door.

We've had it installed for a few months now and we love it. Granted it was a bit pricey, but so far, it's well worth it. The look is great with a large section of clear glass. The handle matches the rest in the house.

Until it falls off. Rather, it pulls out. For some reason the hex set screws keep working themselves loose over time. We've tightened them and tightened them. Short of welding them, I've sent the following to Pella for recommendations:

We purchased a Pella storm door (warranty number 102405 91001 9367)a few months ago and have concerns about the handle. During normal use the handle comes loose from the spindle and occasionally gets pulled off. We have tightened the hex set screw several times but it continues to work itself loose. Is there anything we can use (like Loctite) to keep the set screws tight over time? Is there any maintenance that we should be doing to keep the handles on?

We enjoy our Pella storm door and will continue to buy Pella products in the future.

Thank you.


I'll keep you posted on the outcome.

-----------UPDATE-----------------

Here's the response I got back from Pella (the same day mind you):

Hello,

You could use loctite that should help. I am also sending a d clip to you. That slips over the base of the handle on the backside of the outside plate. You could also turn the spindle a quarter turn to get some fresh metal for the set screw to bite into.

Eric

Thank you

Pella Storm Doors


So, it looks like Loctite may help. We'll see how the D clip works too. And, if need be, the spindle turn.

2 comments:

Anonymous said...

If you dont get a response, let me know - I have a pella rep that i'm sure can point you in the right direction. I spec pella for most everything, and have pella here in the house, and have never had problems with the units or service. I'm sure they'll take care of you.

--cinda

Jdunn36 said...

Thanks for your post! I am having the same problem and thought I must have just done something wrong when installing.